¿Cuál es el nombre apropiado de un campo que reemplaza la "descripción" que está reservada en iOS?

Escribí una IDL de ahorro como la siguiente:

struct Product { 1: string name, 2: string description } 

Después de publicar este IDL, he notado que 'description' es un tipo de 'reservado' en iOS porque la class NSObject tiene un método de class 'descripción' y se supone que este IDL se usa en iOS.

He estado pensando en este tema y tengo algunos candidatos:

  • detalle
  • detalles
  • detalladoTexto
  • descriptionText

Pero no pude averiguar cuál es el mejor (en términos de naturalidad y concisión) ya que no soy un hablante nativo de inglés.

Entiendo que nombrar cosas depende de su área de dominio, pero estoy seguro de que la "descripción" de algo es un concepto bastante común y muchos desarrolladores de iOS están desconcertados con la cosa de NSObject .

Cuando hablamos de convenciones de nomenclatura, debes saber que aquí no hay ningún derecho ni error. Apple publicó un documento que explica por qué usan dicha convención de nombres.

Pero si está buscando una alternativa a su struct , tal vez deba profundizar y alcanzar una convención de nomenclatura C ( struct es de C, no de Objective-C). Y entonces podrías usar Notación húngara por ejemplo, pero no recomendé esto en absoluto.

Esto es lo que hago: siempre nombro mis variables de la class. Esto es lo que hace Apple en algunos casos (mira el método capitalizedString : este método podría denominarse solo con capitalized , ¿verdad? Porque solo puedes usarlo para una cadena). Entonces, en su caso, el nombre será 'descriptionProduct' o 'descriptionOfTheProduct' o incluso 'descProduct'. El caso es que nunca olvidará lo que tiene en mente porque tiene al less "desc" para codificar el sentido, captar el nombre completo para usted.

Si se está conectando a algún tipo de service REST, siempre debe mantener los comienzos de los nombres iguales, ya que simplemente olvidará qué coincide con qué. Entonces, si está recibiendo la forma de "descripción" de su service, use "desc …" (incluso para el sentido del código).

Pero no puedes estar bien o mal respondiendo este tipo de preguntas.

Como esto está en una struct , no entra en conflicto con el método denominado description en absoluto. Puede usar con total security la description aquí.

Sin embargo, tal vez pueda ser más, um, descriptivo, también en su nombre. ¿Qué es la "descripción" que describe? ¿La propia estructura o el producto que representa? Si este último, productDescription sería una excelente opción.

Como dijiste, la description es un post con nombre en NSObject .

Deberías poder utilizarlo en una estructura, pero puedo ver dónde podría causar un problema cuando lo uses . (la finalización automática puede ser buena o mala).

Creo que "detalles" es una buena opción. Si usa algo con "Texto" en el nombre, puede parecer extraño a less que lo haga por otros.

Puede usar una convención como strName , strDescription , etc., para identificar el tipo de la variable y tampoco tendrá un problema.

Si desea poner "Texto" en el nombre de la variable, debe ser consistente ( nameText , descriptionText ), etc.

También podría usar un nombre de variable con una primera letra mayúscula: "Nombre", "Descripción", etc. Sin embargo, esta no es la convención de Apple para nombrar variables.