¿Cómo uso el sdk base ios 4.2 usando Xcode 4.2?

¿Cómo uso el sdk base ios 4.2 usando Xcode 4.2?

Poseo un iPhone 4s y un iTouch que tiene ios 4.2 en él. Después de actualizar Xcode a 4.2 para trabajar con mi iPhone 4s, ya no puedo usar Xcode con mi iTouch. ¿Cómo configuro Xcode para que funcione mi iTouch en 4.2 y mi iPhone en iOS5?

También intenté configurar el sdk base seleccionando otro pero no hay nada más en la list, todo lo que obtuve es una window de dialog en la que puedo escribir manualmente. ¿Debo agregar una opción allí?

Gracias.

Xcode 4.2 viene con soporte de dispositivo para iOS 4.2+ ya instalado. No desea cambiar el SDK base, necesita cambiar el objective de implementación. De forma pnetworkingeterminada, el destino de implementación para un nuevo proyecto en Xcode 4.2 se establece en iOS 5.0. Puede cambiarlo en la pantalla de resumen de configuration del proyecto o en la configuration de configuration del proyecto (es bastante obvio en la pantalla de resumen y simplemente busca 'destino de deployment' en la pantalla de configuration completa). Asegúrese de que está utilizando la configuration completa, y no solo las configuraciones básicas.

Además, asegúrese de que no ha habilitado ninguna configuration solo para iOS 5+ como Storyboards. Su proyecto no se cargará en iOS 4.2 si están habilitados.

EDIT: Según su comentario, creo que puede estar usando un iPod Touch 1G / 2G? Si es así, es la nueva architecture pnetworkingeterminada. Dado que iOS 5 solo se ejecuta en dispositivos armv7, el nuevo proyecto pnetworkingeterminado solo tiene armv7 como una architecture válida. Vaya a la configuration del proyecto y agregue armv6 a las architectures y luego se ejecutará nuevamente en su dispositivo armv6.

http://developer.apple.com/library/mac/documentation/DeveloperTools/Conceptual/WhatsNewXcode/Articles/xcode_4_2.html

Para mejorar el time de descarga y la eficiencia de installation con Xcode 4.2, el instalador Xcode estándar excluye algunos componentes de herramientas grandes, como los simuladores antiguos, que no son esenciales para el set de herramientas de desarrollo actual. Xcode te presenta un dialog cuando se necesita download el simulador. Por lo tanto, las preferences de documentation se han sustituido por las preferences de Descargas, que incluyen documentation y componentes (simuladores y SDK). Con la pestaña Componentes del panel de preferences de descargas, puede ver una descripción de cada componente disponible, downloadla e instalarla.