Cómo solucionar de forma permanente Xcode 5 SpringBoard no se pudo ejecutar la aplicación con error: -3

El lanzamiento de aplicaciones desde Xcode 5 al simulador de iOS (varias versiones de sistema operativo) falla con SpringBoard failed to launch application with error: -3 . Puedo solucionar el problema "apagándolo y volviendo a encenderlo" (abandonando el simulador y reiniciando, desinstalando y volviendo a desplegar la aplicación, etc.), pero parece volver más tarde y en otros proyectos.

¿Alguien puede ayudarme a entender cuál es el verdadero problema aquí y si hay una solución permanente?

No sé por qué, pero al final, eliminar la aplicación del simulador resolvió esto.

Dejar el simulador parece ayudar.

Reinicie el simulador, si no soluciona su problema y luego borra todo el contenido. Funcionó para mí.

Ejecute el Monitor de actividad y fuerce el process del simulador. Luego ejecute la aplicación nuevamente y el simulador se iniciará automáticamente y el problema desaparecerá.

Creo que esto puede deberse a que lo ha instalado (ejecutado) en un simulador de iOS7 de 64 bits y ahora está intentando utilizar la misma installation / files en la simulación de 32 bits.

1) Presione el button de parada de Xcode

2) Salir del simulador

3) Presione nuevamente el button Ejecutar desde Xcode

Esta es la solución más rápida que he intentado, no tuve que eliminar la aplicación ni hacer nada por el estilo.

Noté que comencé a recibir este error al editar manualmente los files que están en el espacio en disco del emulador.

Con "el espacio en disco del Emulador" me refiero a una ruta similar a esta: ~ / Library / Application Support / iPhone Simulator / 7.0 / Applications //. App /

Hacer que el process de construcción vuelva a funcionar resolvió mis problemas también, así que siento que tiene algo que ver con permissions de files o algún tipo de falla de sum de comprobación.