Bolts.framework: se ejecuta en el iPhone 6 pero no en el iPod touch

Estoy haciendo una aplicación de iOS que utiliza notifications push a través del SDK de Parse (instalado con CocoaPods) y para probar que estoy usando tres dispositivos: un iPhone 6, un iPad Air 2 y un iPod touch (5ª generación). La aplicación funciona sin problemas en el iPhone y el iPad.

Al iniciarse en el iPod, sin embargo, se bloquea al generar el siguiente error:

dyld: Library not loaded: @rpath/Bolts.framework/Bolts Referenced from: /private/var/mobile/Containers/Bundle/Application/3436C523-8F1F-445B-8099-435F7554DC96/[app name].app/[app name] Reason: no suitable image found. Did find: /private/var/mobile/Containers/Bundle/Application/3436C523-8F1F-445B-8099-435F7554DC96/Monepp.app/Frameworks/Bolts.framework/Bolts: mach-o, but wrong architecture /private/var/mobile/Containers/Bundle/Application/3436C523-8F1F-445B-8099-435F7554DC96/Monepp.app/Frameworks/Bolts.framework/Bolts: mach-o, but wrong architecture /private/var/mobile/Containers/Bundle/Application/3436C523-8F1F-445B-8099-435F7554DC96/Monepp.app/Frameworks/Bolts.framework/Bolts: mach-o, but wrong architecture 

Soy consciente de que el iPod usa una architecture diferente a la de los otros dos (32 bits en lugar de 64 bits), pero la aplicación también funciona normalmente con un simulador de iPhone 4s, que debería usar la misma architecture que el iPod.

He intentado limpiar, comprobar las architectures de destino del marco, volver a instalar el marco e instalar una versión diferente del marco, pero nada ayudó.

Lo que también es curioso es que hace unos meses hice una aplicación en Objective-C usando Parse que funcionaba normalmente en el iPod. ¿Algunas ideas?

ACTUALIZACIÓN: desde que se actualizó a iOS 9, el error ya no se ha producido.