Apple aceptará aplicaciones creadas solo con Xcode 5

Estoy haciendo una aplicación en Xcode 4.5. Ayer escuché que Apple rechazará las comstackciones que se crean debajo de Xcode 5 y que no son compatibles con iOS 7. ¿Es precisa esta información?

Eso es correcto. Apple no aprobará las aplicaciones comstackdas con versiones Xcode debajo de 5.0.

Sí, Apple ahora solo acepta versiones de Xcode5. Esto es aplicable desde el 1 de febrero de 2014.

Aquí está el enlace: https://developer.apple.com/news/?id=12172013a

Por lo tanto, su compilation debe comstackrse desde Xcode5 para su envío en la App Store; de ​​lo contrario, Apple rechazará su aplicación.

Sí. Según este anuncio de Apple , desde el 2014 hasta el 01 de febrero, un desarrollador solo puede enviar aplicaciones creadas con Xcode 5.x (o presumiblemente versiones posteriores). Las comstackciones menores no pasarán la validation durante un bash de enviarlas.

Y Xcode 5 solo es compatible con la creación de aplicaciones con iOS 7 SDK. El uso de cualquier SDK inferior con Xcode 5 no es compatible, y las aplicaciones creadas con tales también no pueden enviarse. Puede establecer un objective de implementación más bajo para su aplicación, como iOS 5.1 o 6.0, si su aplicación admite no solo iOS 7, sino también las versiones inferiores. Pero uno debería hacer esto solo si testing la aplicación en dispositivos reales con todas las versiones de iOS reclamadas, ya que usar solo el iPhone Simulator no es una testing exhaustiva de compatibilidad con el sistema operativo.

Tenga en count que es probable que se deba modificar una aplicación anterior al comstackrla con el SDK de iOS 7, ya que varias de las métricas de control de la interfaz de usuario y las posiciones de window / vista pnetworkingeterminadas se han cambiado de iOS 6 y SDK anteriores.

Sí, eso es exactamente lo que Apple hace. Debería haber recibido al less un correo a su count de desarrollador con esa información.

Sí, Apple no aceptará la aplicación creada debajo de xcode5. A partir del 1 de febrero, las nuevas aplicaciones enviadas a la App Store deben estar compuestas con la última versión de Xcode (Xcode5) y deben optimizarse para iOS 7.