Aplicación de debugging con iOS 4.0 Simulator en iOS 5 SDK

Estoy usando el último XCode (4.2), y necesito depurar completamente 4.1, 4.2, 4.3. Actualmente, el menu desplegable en la esquina superior izquierda solo me da la opción de depurar con el simulador con la versión 4.3 o 5.0. Realmente necesito probar 4.0, 4.1, 4.2 más a background. Como parece que no puedo encontrar una forma confiable de rebajar mi dispositivo de testing (3GS) de 5.0 a 4.0+ (nunca fue jailbroken), el simulador parece ser mi única opción para garantizar la máxima compatibilidad.

¿Alguien puede señalarme en la dirección correcta en términos de configurar correctamente el simulador para las versiones anteriores de iOS?

¡Gracias!

Haga clic en su destino en Xcode Navigator (el elemento más avanzado), select Build Settings , vaya a Deployment . Allí puede seleccionar varios iOS Deplyment Targets .