Alamofire Xcode 8 Swift 3 resultados en 786 errores de compilation

Estoy usando el Xcode 8.0 GM. Creé una aplicación pnetworkingeterminada de vista única con mi objective de implementación establecido en 9.0.

En mi Podfile, me dirijo a la sucursal de Swift 3:

source 'https://github.com/CocoaPods/Specs.git' platform :ios, '9.0' use_frameworks! target 'MyProject' do pod 'Alamofire', :git => 'https://github.com/Alamofire/Alamofire.git', :branch => 'swift3' end 

Puedo ejecutar la Installing Alamofire (4.0.0-beta.2) y get … Installing Alamofire (4.0.0-beta.2) … fantástico, sin problemas. Abro MyProject.xcworkspace

Esto aparece:

convertir Alamofire a la última sintaxis

No puedo pegar más tarde porque me dice:

Xcode 8 no podrá build el objective "Alamofire", y ciertas funciones de edición no funcionarán correctamente hasta que el código fuente de Swift en este objective se haya convertido.

Eso no sirve, quiero buildlo. Entonces presioné "Convertir". Me da opciones:

convertir a Swift 3

Bueno, eso es lo que quiero, Swift 3. Parece bueno, presiono "next".

seleccionar objetivos

Asume por defecto estos 3 objectives seleccionados. Ok bien, golpeé luego.

error 1 error 2

Lo que en el santo nombre de Dios …

Quiero usar la twig swift3 de swift3 en un proyecto Xcode 8, Swift 3 dirigido a iOS 9.0. ¿Dónde me equivoqué y cómo puedo hacer que funcione? FWIW Tengo un montón de errores tratando de usar la twig Swift 2.3 de Alamofire, así que sé que es algo que estoy haciendo mal.

Actualización a los últimos Cocoapods (en el momento de esta respuesta: versión 1.1.0.beta.2 ) mediante el command:

gem install cocoapods --pre parecía resolver el problema de mi circunstancia.

Pude hacerlo funcionar:

actualizar:

 # Uncomment this line to define a global platform for your project # platform :ios, '9.0' target 'PROJECT NAME HERE' do # Comment this line if you're not using Swift and don't want to use dynamic frameworks use_frameworks! pod 'Alamofire', :git => 'https://github.com/Alamofire/Alamofire.git', :branch => 'swift3' end 

actualización de la pod Alamofire

Debería actualizarse a 4.0.0-beta.2

Hay algunos cambios al get una request:

antiguo:

 Alamofire.request(URL_NAME_HERE, withMethod: .get).responseJSON { response in //Code here. } 

nuevo:

 Alamofire.request(URL_NAME_HERE, method: .get).responseJSON { response in //Code here. } 

Espero que esto ayude.

Debería usar la twig master ahora, ya que la twig swift3 se ha fusionado allí. Además, es normal que Xcode Migrator muestre muchos errores. Lo que está haciendo es comstackr el código pensando que es una versión Swift henetworkingada, pero como ya está en Swift 3.0, los errores son esperables. Finalmente, Xcode le pide que se convierta a la syntax moderna de Swift probablemente porque no ha usado la última versión de Cocoapods para instalar Alamofire.

NB: evento aunque Cocoapods te dice que uses gem install cocoapods --pre , prefiero usar gem update cocoapods --pre . De lo contrario, la versión anterior de Cocoapods se queda y aún se usa cuando se usa la pod update . Comtesting qué versión estás utilizando con pod --version .

Actualice el pod a 1.1.0.rc utilizando el siguiente command.

sudo gem install cocoapods

usa el fragment de golpe al final.

post_install do |installer| installer.pods_project.targets.each do |target| target.build_configurations.each do |config| config.build_settings['SWIFT_VERSION'] = '3.0' end end end

esto ayuda.

La solución es cambiar su request de este

 pod 'Alamofire', :git => 'https://github.com/Alamofire/Alamofire.git', :branch => 'swift3' 

a esto

 pod 'Alamofire', :git => 'https://github.com/Alamofire/Alamofire.git', :branch => 'master' 

Solucioné un problema similar al usar

 pod 'Alamofire', '~> 4.0' 

en el file pod. Tuve que ajustarme a un objective de implementación mínimo más alto.

Resolví un problema similar usando:

 platform :ios, '9.0' use_frameworks! target 'PROJECT NAME HERE' do pod 'Alamofire' end post_install do |installer| installer.pods_project.targets.each do |target| target.build_configurations.each do |config| config.build_settings['SWIFT_VERSION'] = '3.0' end end end 

Tuve el mismo problema, pero desinstalé cocoapods, desinstalé alamofire, luego actualicé mis cápsulas de cocoa a 1.1.0.beta.2, luego utilicé la twig Swift3-rebased de Alamofire en mi file pod

pod 'Alamofire', :git => 'https://github.com/Alamofire/Alamofire.git', :branch => 'swift3-rebased'

abrió mi file Project .xcworkspace y todos los errores de compilation para Alamofire se habían ido.

No estoy seguro de si esto ayuda a nadie, pero por si acaso .. Intenté agregar Alamofire a una aplicación rápida de muestra en Xcode 8.0 GM con la aplicación independiente CocoaPods … Seguí recibiendo la window Convert to swift 2.3 o 3.0 … pero luego intenté desde la línea de command a la actualización de pod y funcionó. No tengo idea de por qué … Supongo que los commands subyacentes para la aplicación independiente son los mismos … así que no estoy seguro de qué fue lo que marcó la diferencia. En cualquier caso, después de 30 minutos de time perdido, la mina funciona.

CocoaPods captura de pantalla de la aplicación Mac independiente

Esta es la captura de pantalla de la línea de command .. mismo file pod

introduzca la descripción de la imagen aquí

pod 'Alamofire', '~> 4.0' utilizar la versión 4.0 pod 'Alamofire', '~> 4.0' notar que se necesita CocoaPods 1.1.