Agregue Parse.com 1.11.0 a watchOS 2

En la actualización SDK de Parse a 1.11.0, dice que es compatible con watchOS y tvOS. Me preguntaba cómo puedo agregar los frameworks a mi aplicación watchOS usando Cocoapods. El file pod contiene pod 'Parse' y he ejecutado la pod update luego la pod install pero cuando agrego un encabezado de connection a la extensión watchOS 2, dice que no se encontró el file.

¿Sabes lo que debería estar haciendo?

Gracias

Parece que las instrucciones de Inicio rápido no se han actualizado para watchOS 2. Tampoco pude encontrar ninguna información en el anuncio .

Si solo necesita usar Parse en su objective de Extensión WatchKit, entonces un simple Podfile similar a esto funcionará:

 # Uncomment this line to define a global platform for your project # platform :ios, '8.0' # Uncomment this line if you're using Swift # use_frameworks! target 'MyApp' do end target 'MyApp WatchKit App' do end target 'MyApp WatchKit Extension' do platform :watchos, '2.0' pod 'Parse', '~> 1.11' end 

Sin embargo, si necesita usar Parse tanto en su objective de iOS como en el objective de la Extensión de WatchKit (por ejemplo, para registrarse en Push Notifications en iOS y comunicarse con Parse en WatchKit), las cosas son un poco más complicadas.

Debido al error "UUID duplicado generado" en CocoaPods , necesitará solucionar el problema , primero ejecutándolo en su terminal:

 export COCOAPODS_DISABLE_DETERMINISTIC_UUIDS=YES 

A continuación, puede crear un Podfile como este:

 # Uncomment this line to define a global platform for your project # platform :ios, '8.0' # Uncomment this line if you're using Swift # use_frameworks! target 'MyApp' do platform :ios, '8.0' pod 'Parse', '~> 1.11' end target 'MyApp WatchKit App' do end target 'MyApp WatchKit Extension' do platform :watchos, '2.0' pod 'Parse', '~> 1.11' end 

Finalmente, la pod install , ¡y deberías estar listo!