Advertencia de análisis de dependencia de Xcode 8

Estoy tratando de eliminar estas advertencias que aparecen en xcode (8.3):

warning: using 'ALWAYS_SEARCH_USER_PATHS = YES' while building targets which define modules ('DEFINES_MODULE = YES') may fail. Please migrate to using 'ALWAYS_SEARCH_USER_PATHS = NO'. 

Cuando cambio 'ALWAYS_SEARCH_USER_PATHS' a NO en la configuration de compilation del objective, las advertencias desaparecen. Pero luego recibo advertencias adicionales cuando ejecuto la pod install :

 [!] The `AppName [Release]` target overrides the `ALWAYS_SEARCH_USER_PATHS` build setting defined in `Pods/Target Support Files/Pods-AppName/Pods-AppName.release.xcconfig'. This can lead to problems with the CocoaPods installation - Use the `$(inherited)` flag, or - Remove the build settings from the target. 

Efectivamente, cuando miro en Pods/Target Support Files/Pods-AppName/Pods-AppName.release.xcconfig , ALWAYS_SEARCH_USER_PATHS = YES está allí y no estoy seguro de cómo llegó allí o de dónde vino ese file.

¿Alguien sabe cómo deshacerse de estos errores? Gracias.

Xcode 8.3, que ALWAYS_SEARCH_USER_PATHS ahora está en desuso :

La configuration de compilation "Siempre search routes de usuario" está en desuso y es posible que no sea compatible con una versión futura de Xcode. Los proyectos que confían en esta característica deberían migrar a la semántica de usuario independiente vs. encabezado del sistema y establecer esta configuration de compilation en "No". (16364329)

Marque: https://developer.apple.com/library/content/releasenotes/DeveloperTools/RN-Xcode/Chapters/Introduction.html

Lee, ¿puedes proporcionar tu file pod?

Desde la versión Xcode 8.3, el ALWAYS_SEARCH_USER_PATHS ahora está en desuso, pero otras bibliotecas que todavía están usando ALWAYS_SEARCH_USER_PATHS están poniendo el valor de configuration en su proyecto, tendrá que esperar a que otras bibliotecas también hagan sus cambios.

Por ejemplo, el Core Plot actual está en la versión 2.2, todavía pone el valor ALWAYS_SEARCH_USER_PATHS en mi proyecto, la solución para esta advertencia se lanzará en la versión 2.3